PDA

View Full Version : Dead's 99 Volvo V70R



Dead91silvia
07-14-2013, 02:28 PM
I wasnt gonna start a thread for this one, but it is a Turbo wagon so why the hell not! :grin:

My OP from Swedespeed...
http://forums.swedespeed.com/showthread ... ct-99-V70R (http://forums.swedespeed.com/showthread.php?195412-New-project-99-V70R)

"I just picked up a 99 V70R as a project from a buddy that didnt have time to finish it.

It's in pretty good shape from what I can tell. He installed a new motor and assorted parts. Also had the turbo rebuilt and installed a S60R manifold. All that is left to do is the pluming and wiring. So I'm hoping I can find a little bit of help with it.

The only Volvo's I'm used to are my 122's and 140's. haha.... I know a ton about Subaru's but they are like apples and oranges. not sure how long I'll keep it, but I have wanted one since I was in high school and now I have one. "


https://sl-i.net/FORUM/images/imported/2013/07/v70r1_zps55aee38d-1.jpg (http://s1155.photobucket.com/user/dead91silvia/media/99%20v70r/v70r1_zps55aee38d.jpg.html)


https://sl-i.net/FORUM/images/imported/2013/07/v70r_zps31939508-1.jpg (http://s1155.photobucket.com/user/dead91silvia/media/99%20v70r/v70r_zps31939508.jpg.html)

I got some time to mess with it today... Here are some more pics. I did a little work to it yesterday, like installed the ECU's and PS tank.

https://sl-i.net/FORUM/images/imported/2013/07/IMG_2872_zps3256b7c3-1.jpg (http://s1155.photobucket.com/user/dead91silvia/media/99%20v70r/IMG_2872_zps3256b7c3.jpg.html)

https://sl-i.net/FORUM/images/imported/2013/07/IMG_2881_zpsb39b45f2-1.jpg (http://s1155.photobucket.com/user/dead91silvia/media/99%20v70r/IMG_2881_zpsb39b45f2.jpg.html)

The interior is not bad at all.
https://sl-i.net/FORUM/images/imported/2013/07/IMG_2867_zps280f9cf8-1.jpg (http://s1155.photobucket.com/user/dead91silvia/media/99%20v70r/IMG_2867_zps280f9cf8.jpg.html)

https://sl-i.net/FORUM/images/imported/2013/07/IMG_2868_zpsa331abe1-1.jpg (http://s1155.photobucket.com/user/dead91silvia/media/99%20v70r/IMG_2868_zpsa331abe1.jpg.html)

https://sl-i.net/FORUM/images/imported/2013/07/IMG_2869_zps32a154bd-1.jpg (http://s1155.photobucket.com/user/dead91silvia/media/99%20v70r/IMG_2869_zps32a154bd.jpg.html)

Not a fan of these wheels...
https://sl-i.net/FORUM/images/imported/2013/07/IMG_2870_zpsf09fbf8e-1.jpg (http://s1155.photobucket.com/user/dead91silvia/media/99%20v70r/IMG_2870_zpsf09fbf8e.jpg.html)

I didnt take a pic with the ECU box and PS/overflow tanks out before working on it, but you guys get the idea.

https://sl-i.net/FORUM/images/imported/2013/07/IMG_2855_zpscb69dd3b-1.jpg (http://s1155.photobucket.com/user/dead91silvia/media/99%20v70r/IMG_2855_zpscb69dd3b.jpg.html)

After about 2 hours...
https://sl-i.net/FORUM/images/imported/2013/07/IMG_2896_zpsa55c95a4-1.jpg (http://s1155.photobucket.com/user/dead91silvia/media/99%20v70r/IMG_2896_zpsa55c95a4.jpg.html)

I'm now to the point where I need some help though... I have some cables and other random things I cant figure where they go. Like I said, I have never had one of these cars before, let alone even driven one.

Upper heater core line wont go in all the way/clip in, not sure why.
https://sl-i.net/FORUM/images/imported/2013/07/IMG_2898_zpsd4f27156-1.jpg (http://s1155.photobucket.com/user/dead91silvia/media/99%20v70r/IMG_2898_zpsd4f27156.jpg.html)

Found all the plugs... now where does it mount? (It will be getting replaced since it's a little busted up)
https://sl-i.net/FORUM/images/imported/2013/07/IMG_2892_zps9915555c-1.jpg (http://s1155.photobucket.com/user/dead91silvia/media/99%20v70r/IMG_2892_zps9915555c.jpg.html)

I'm assuming this is a ground? It's on the same harness as the ECU. not sure where its supposed to go and would like to install it correctly.
https://sl-i.net/FORUM/images/imported/2013/07/IMG_2885_zps79b34749-1.jpg (http://s1155.photobucket.com/user/dead91silvia/media/99%20v70r/IMG_2885_zps79b34749.jpg.html)

the main ground strap... I think I figured out part of it.. It was just chilling in a box so I'm just guessing.

https://sl-i.net/FORUM/images/imported/2013/07/IMG_2886_zps5de1e305-1.jpg (http://s1155.photobucket.com/user/dead91silvia/media/99%20v70r/IMG_2886_zps5de1e305.jpg.html)

I routed one wire under the batt tray. I saw a bolt part threaded on and figured thats what it was for..
https://sl-i.net/FORUM/images/imported/2013/07/IMG_2888_zps46ddd648-1.jpg (http://s1155.photobucket.com/user/dead91silvia/media/99%20v70r/IMG_2888_zps46ddd648.jpg.html)

And I'm lost with this... haha.. Where the hell do these go?!
https://sl-i.net/FORUM/images/imported/2013/07/IMG_2890_zps7c9fac75-1.jpg (http://s1155.photobucket.com/user/dead91silvia/media/99%20v70r/IMG_2890_zps7c9fac75.jpg.html)

Those are my main problems right now, just need to know where they go and/or how to fix them. I'm so used to Subaru's, this is new to me by far.

harrymaneuvers
07-14-2013, 03:02 PM
Nice!!!

I always loved the looks of the V70R.

foohfooh
07-15-2013, 10:37 AM
oooh swedish luxary.

foohfooh
07-15-2013, 10:38 AM
i thought these had little spoilers?

Muse
07-15-2013, 02:17 PM
So, are you just gonna drive it or do you have some plans for madness?

Dead91silvia
07-16-2013, 01:49 AM
Probably sell it when I'm done... Would like to keep it, but it's really just a flip.

Dead91silvia
07-23-2013, 12:22 PM
Took her for a drive... Pretty damn fast for being an auto!

Now I get to fix a few more problems.... CEL for an o2 sensor and the alternator is acting weird... not charging.

danieltrusty
08-19-2013, 03:58 AM
i always kinda wanted a volvo wagon

Dead91silvia
09-04-2013, 11:14 AM
Anyone wanna buy this? Has a charging and cooling problem. I have way too much going on to care to fix it now.

Dead91silvia
01-02-2014, 12:49 PM
Well.. Got the paper work figured out and it's now in my name. Only problem I can really see is that it has a rattle when rotating and a door sensor for the right rear door needs to be replaced, but I'll let the next person worry about that.

Had plans to sell it for an enclosed car trailer (storage for when I move), but might be trading it for a car... Not sure yet.

Muse
01-03-2014, 08:27 PM
Oh, dear... what kind of car?

Zangado1
01-03-2014, 10:13 PM
Volvo's are bad ass. My 02 S60 is an AWD 5 cylinder turbo pushing 265 hp stock with a tiptronic trans. So nice car "Dead" especially with the "R' option.https://sl-i.net/FORUM/images/imported/2014/01/Eibach4_zpsf27705c5-1.jpg

Dead91silvia
01-04-2014, 02:13 AM
Oh, dear... what kind of car?

Ehh... I'll let you sweat it till Sunday, at least. Will know by then if we want to or not.

I do like it, but I really want a 5 speed if I was to do anything to it. It also did cross my mind to swap it to an EVO drive-train. :smt005 It would be so much easier to work on. :grin:

Legacy89
01-04-2014, 06:57 AM
Worked on a S40 around new years, decent car, but unfortunately some French engineer had a finger in the electronics department.
Nearly took me an hour to hook up the relay for a set of driving lights with the ground switched crap.

Muse
01-06-2014, 12:24 AM
Alright, Sunday's come and gone (at least on the right coast)
What's the plan?

Dead91silvia
01-06-2014, 03:14 AM
The other car sold... So I'm just gonna get this one detailed and get it ready to market.

EJ22D
01-10-2014, 07:32 PM
I am a former owner of a few T5s & let me tell you that it's rather EASY to get 300bhp out of these. However, if you ever have to do a PCV or heater core job, you're in for an interesting time. I loved my 850-R. These run SUPER smooth & are pretty much bulletproof when cared for. This R looks like a great catch & is most certainly worth the time to fix. The TQ band to these T5s are ridiculous.

Dead91silvia
01-10-2014, 09:45 PM
Yeah, I need to get it all detailed up and get it sold. It really is a nice care to drive, I just have too many right now.

Dead91silvia
02-20-2014, 01:55 PM
Well, it's gone.. Developed oiling problems... Lost a ton of money on it, staying away from Volvo from now on.

Muse
02-20-2014, 06:35 PM
Staying away from Volvo entirely? Or newer Volvos?

ctbrighton
02-20-2014, 10:22 PM
the pvc get all clogged up? or is the oil pickup sucking air?

i hear ya though, all the little things add up and ya just wanna ditch it.

keep it simple and stick with what ya know

Dead91silvia
02-20-2014, 11:28 PM
I'm not sure... It started blowing blue out the tail pipe and had no oil pressure. I was done with it.