PDA

View Full Version : Red85Celica's 1989 GL-10 turbo. For sale 11/25



Red85Celica
05-02-2014, 06:19 AM
I really wasn't searching for another vehicle but this one just kind of happened. Its a 1989 gl-10 turbo, 207k on the clock, super clean for its age. Automatic, awd, power everything.

How I obtained this car...well my buddy messaged me on Facebook and asked if I was interested in a free Subaru wagon and if so give him a call. So I call him up and he says well its an '89 (immediately I was thinking, no.) and its turbo. Its been sitting for about 5 years and it looks straight, interior is decent. Gave me a run down on some issues it supposedly had. Come to find out the car is about 2 miles from my house.

https://sl-i.net/FORUM/images/imported/2014/05/ahyhu8yv-1.jpg
https://sl-i.net/FORUM/images/imported/2014/05/bu5enyse-1.jpg

Anyways, dead91silvia (robin) and I head over there with my Toyota and his truck/trailer. I yanked it out with my winch and we towed backwards up the driveway to the main road and loaded it up. Got it home and hit it with a pressure washer, soap, purple power and a stiff brush. 1 hour later its looking pretty good!
https://sl-i.net/FORUM/images/imported/2014/05/nujy6u4a-1.jpg
https://sl-i.net/FORUM/images/imported/2014/05/zery4aby-1.jpg
https://sl-i.net/FORUM/images/imported/2014/05/uvuhupym-1.jpg
https://sl-i.net/FORUM/images/imported/2014/05/esa6ures-1.jpg
https://sl-i.net/FORUM/images/imported/2014/05/ehu3etur-1.jpg

https://sl-i.net/FORUM/images/imported/2014/05/azu4u2es-1.jpg
https://sl-i.net/FORUM/images/imported/2014/05/se5y4e2y-1.jpg
https://sl-i.net/FORUM/images/imported/2014/05/meqavu3y-1.jpg
https://sl-i.net/FORUM/images/imported/2014/05/ypuvu5yd-1.jpg

So keep in mind this car has been sitting since January 2008. The interior isn't moldy or wet, just smells a bit. It has approx 3/4 tank of gas which after a bit of investigation we found it smells fresh, no joke it was like someone just filled it up. So we hooked up jumper cables to the battery and it fired right up.

https://sl-i.net/FORUM/images/imported/2014/05/a2ype6eq-1.jpg

Turns out the previous owner heard a noise while driving, got home and shut the car off. After that it would not start. Turns out it had a shitty led terminal on the positive side that did not make a good connection.

So the plan is to replace a few things like the timing belts, oil pump, oil seals and see if it cures some symptoms. If it does then I will work on the electrical and cosmetics like the bumper cover and tail light.

Sent from my XT1080 using Tapatalk

Red85Celica
05-02-2014, 06:27 AM
I asked the owner if I could have any records kept for maintenance on the car. All I have to say is it was very well taken care of...the a/c still blows cold and it has not been retrofitted.
Cylinder heads were replaced along with many other parts around 180k, total bill almost $3,000 back in '04.

Sent from my XT1080 using Tapatalk

98legwag
05-02-2014, 07:29 AM
Thats pretty freakin sweet.

twoheadedboy
05-03-2014, 05:52 PM
Your a very lucky person finding a turbo Subaru for free that starts right up with only a jump!

Dead91silvia
05-03-2014, 10:24 PM
Less then 3 hours after picking it up, we took it for a drive! Fun times!

nikolaus.conrad
05-21-2014, 10:53 PM
Super jealous

Red85Celica
05-23-2014, 03:48 PM
I should sell it on the east coast. Only a small amount of rust on the tail gate.

Red85Celica
06-04-2014, 06:37 AM
Slowly getting the car cleaned up. Need to replace oil pump and some seals. Going to do timing belts while its apart.

https://sl-i.net/FORUM/images/imported/2014/06/9evezy4y-1.jpg
https://sl-i.net/FORUM/images/imported/2014/06/nemuruza-1.jpg
https://sl-i.net/FORUM/images/imported/2014/06/2e6u5u5e-1.jpg

Sent from my XT1080 using Tapatalk

Red85Celica
07-05-2014, 05:08 AM
Triple post.

Red85Celica
07-05-2014, 05:08 AM
Triple post.

Red85Celica
07-05-2014, 05:09 AM
Fully detailed and listed for sale. Had one guy come and take a look but the oil pump and timing belt replacement was a bit to much work for him. So I decided to fix it and the other cosmetic stuff.

DSLR pics
https://sl-i.net/FORUM/images/imported/2014/07/y5uba4u6-1.jpg
https://sl-i.net/FORUM/images/imported/2014/07/uqaqa5y3-1.jpg
https://sl-i.net/FORUM/images/imported/2014/07/ume3equv-1.jpg
https://sl-i.net/FORUM/images/imported/2014/07/e5e7eta3-1.jpg
https://sl-i.net/FORUM/images/imported/2014/07/udu6esed-1.jpg
https://sl-i.net/FORUM/images/imported/2014/07/ugyqu7eq-1.jpg

https://sl-i.net/FORUM/images/imported/2014/07/ugyju9e5-1.jpg
https://sl-i.net/FORUM/images/imported/2014/07/7adysu8e-1.jpg
https://sl-i.net/FORUM/images/imported/2014/07/bu8any2e-1.jpg
https://sl-i.net/FORUM/images/imported/2014/07/upa5a7en-1.jpg
https://sl-i.net/FORUM/images/imported/2014/07/epe3amu6-1.jpg

Tore the timing covers off....actually broke them is more like it. Found it has Subaru belts so I will reuse those. Camshaft and crankshaft seals are getting replaced along with the idlers etc.

Going to make a JY run and get a new headlight,tail light, bumper cover and some other small stuff it needs. Then it will be back up for sale for more.

thenines'
07-06-2014, 05:01 PM
I have a perfect set of hubcaps for that sweet ride (free-just the cost of shipping)-kept them from my '94 loyal (it was crushed by a tree :smt010 )

Muse
07-06-2014, 05:10 PM
T-T-T-TRIPLE POST!!!!!!

What's it going for?

Red85Celica
07-06-2014, 05:37 PM
I'll let ya know on the hubcaps nines.

I had the car listed at $1200. After everything is fixed up I def will ask more. Maybe $1800. just realized it posted 3 times. Using Tapatalk with a bad signal.

thenines'
07-06-2014, 05:45 PM
Sweet.

Muse
07-06-2014, 10:03 PM
Dude, good luck. that thing is freaking gorgeous... in this... kinda ugly way. Like an A-10 Warthog.

thenines'
07-07-2014, 04:42 AM
Dude, good luck. that thing is freaking gorgeous... in this... kinda ugly way. Like an A-10 Warthog.
These things ROCK in the snow-better then leggys!

Red85Celica
10-11-2014, 06:29 AM
Finally started replacing the oil seals and pump seals. The belts and idlers are new, belts are factory and in excellent shape.

When the car got to operating temp the oil pressure dropped and it had a low end knock. Its fine when cold. I'm hoping fixing the profuse leaks from the oil pump and other oil seals that the knock goes away.

Also getting all new timing covers thanks to the bolts not coming out.

thenines'
10-17-2014, 05:15 AM
If it's leaking-its a loyal :smt005 Did you replace the cork valve cover gaskets? You still need my hubcaps.

Red85Celica
10-17-2014, 06:09 AM
If it's leaking-its a loyal :smt005 Did you replace the cork valve cover gaskets? You still need my hubcaps.
Haven't done the valve cover gaskets, I don't think they were leaking. I finished resealing the oil pump, replacing camshaft seals, crank seal and all timing components... Easiest t-belts ever.
Fired it up and let it run, it gets to operating temp and still has oil pressure and the low end knock is gone but it rattles, I guess you could say. I am told they are really noisy motors. Its also only been driven about 2 miles since it was parked 6 + years ago. So I think I will assemble the rest of it, insure it and drive it for a while.

I'll have to pass for now on the hubcaps until I drive the car and do more diagnosing. Probably not going to put anymore money in to the car if I don't have to.

JBCLEGACY
10-17-2014, 09:30 AM
That is an amazing find! I can't believe how 'clean' that is, nice work getting it up and running..
If you were closer to the east I might've considered it for myself

Red85Celica
10-18-2014, 02:09 AM
That is an amazing find! I can't believe how 'clean' that is, nice work getting it up and running..
If you were closer to the east I might've considered it for myself
Thanks! Can't pass up a free car. My buddy and I were really surprised at how well it cleaned up.

Got everything pretty much back together and insured the car. Hopefully the rain let's up tomorrow so I can finish.

Red85Celica
10-18-2014, 10:00 PM
Out for a drive today. Waiting at dead91silvia's place.
https://sl-i.net/FORUM/images/imported/2014/10/202e96be21a83794fbf9d7575ee7f2b5-1.jpg
https://sl-i.net/FORUM/images/imported/2014/10/353e96b85d69a3b23ddf94b7a8764ce9-1.jpg
https://sl-i.net/FORUM/images/imported/2014/10/5dd5c782f2ea868d599a5546e3c10ff7-1.jpg

Added 6 gallons of 92 octane to the old fuel which cleared up a lot of noise. Running very quiet now. Have some lighting and cosmetic issues to fix now. I will drive it until my new trans is installed in the legacy.

Red85Celica
10-19-2014, 03:09 PM
My spare legacy cargo liner fits perfectly.
https://sl-i.net/FORUM/images/imported/2014/10/99f95f8368f5bebc1603988f98a2f3c0-1.jpg

Muse
10-19-2014, 04:08 PM
Wow, down to the little tweak in the left wheel well...

Red85Celica
10-19-2014, 04:10 PM
Wow, down to the little tweak in the left wheel well...
Lol huh?

thenines'
10-19-2014, 05:33 PM
Didn't know that had crome wheels! I'm still sending you the hubcaps-the only thing that doesn't rot away on a subaru in the northeast.

Red85Celica
10-19-2014, 08:00 PM
https://sl-i.net/FORUM/images/imported/2014/10/35cf65945ad57d37dc15fb61e1b47446-1.jpg

Red85Celica
10-25-2014, 07:57 AM
Still driving the GL daily. Had a guy interested but didn't show up two days in a row, haven't heard from him since. So I pulled the cl ad and bought some new wheels and tires. Going to finish fixing and drive through the winter or until my legacy is fixed.

Swampers came with the wheels.
https://sl-i.net/FORUM/images/imported/2014/10/270b31b8eb46914525d25a086456e4f4-1.jpg

28" x8.5x14
https://sl-i.net/FORUM/images/imported/2014/10/e5812b17e2b42cf2daf9c549197caf31-1.jpg
https://sl-i.net/FORUM/images/imported/2014/10/d0b403094a50e416a35bb608ef22ee73-1.jpg

Muse
10-25-2014, 04:34 PM
Well, they look a little too beat... but you ought to run something like that...

Red85Celica
10-25-2014, 04:45 PM
The thought crosses my mind. [emoji4]

thenines'
10-26-2014, 06:02 PM
These cars ROCK with swampers!

Red85Celica
10-26-2014, 11:35 PM
Put just over 200 miles on the car now. Got all the old fuel burned up and put a full tank of 92 octane in then changed the fuel filter.
New tires ordered for the Peugeot wheels.


Car is running like a champ!

Red85Celica
10-28-2014, 04:25 PM
Turbo on
https://sl-i.net/FORUM/images/imported/2014/10/7032b7943ab0bc4468c2ea95195c1f8c-1.jpg

Turbo off
https://sl-i.net/FORUM/images/imported/2014/10/92c3ff26e1f67383dc0f2ddfbe1b93d2-1.jpg

New tires mounted. 195/60 14

https://sl-i.net/FORUM/images/imported/2014/10/203553d5f0b43e81a0bcfd8f3e68c94d-1.jpg

Old tires. On borrowed time.
https://sl-i.net/FORUM/images/imported/2014/10/6230ae5e2c4d2033a44203977605cc81-1.jpg

Muse
10-28-2014, 04:49 PM
Hold on... turbo on and off? You can turn a turbo off?

Red85Celica
10-28-2014, 04:53 PM
Hold on... turbo on and off? You can turn a turbo off?
Haha yes, with the gas pedal!

Muse
10-28-2014, 04:55 PM
ohhhh, okay... it shows when you're on boost, then?

Red85Celica
10-28-2014, 04:57 PM
ohhhh, okay... it shows when you're on boost, then?
Correct. I'm going to install one of my inexpensive boost gauges. Wish I still had the factory lamco gauge from my parts wrx.

meepers
10-29-2014, 01:52 AM
Awesome find. Love the moss growing on it when you found it!

Red85Celica
11-01-2014, 04:03 PM
Peugeot wheels are on!
https://sl-i.net/FORUM/images/imported/2014/11/b914b75e30e8ace2675ca3dd3af7c74d-1.jpg

Really want to level out the front.

twoheadedboy
11-01-2014, 06:35 PM
That's looking really good! Are you still planning to sell it in the spring?

Red85Celica
11-01-2014, 06:42 PM
That's looking really good! Are you still planning to sell it in the spring?
Yeah I'll be selling it soon. I'd like to finish fixing cosmetics. Needs some stuff though, like brakes and struts up front.

nepbug
11-01-2014, 09:44 PM
Doing good, fun project

Sent from my DROID RAZR HD using Tapatalk

Red85Celica
11-07-2014, 06:11 PM
Tinkered with the GL today. Just put its second full tank of 92 octane in. Had a bit of a miss at idle and I'm only getting 15mpg on this fill up. I picked up some new plugs on the way home and threw them in, old ones looked pretty bad and since I have ran about 8-10 gal of old fuel threw it I figured they would be fouled.
https://sl-i.net/FORUM/images/imported/2014/11/ac600dad0a5da528077c69f6e7b7f1cf-1.jpg

While I was doing the plugs I popped the dist cap off and cleaned the contacts, adjusted all the slack out of the throttle cable and replaced the two turbo heat shield bolts that were missing.

So far I put almost 500 miles on the car, checking everything to make sure it works. I need to do front brakes soon and probably struts and mounts up front cause they are toast and cause a vibration at 55-65mph.

peugoby
11-07-2014, 06:25 PM
So far I put almost 500 miles on the car, checking everything to make sure it works. I need to do front brakes soon and probably struts and mounts up front cause they are toast and cause a vibration at 55-65mph.

Is it ready for the race tomorrow? last car to 50mph buys lunch.

Red85Celica
11-07-2014, 10:59 PM
So far I put almost 500 miles on the car, checking everything to make sure it works. I need to do front brakes soon and probably struts and mounts up front cause they are toast and cause a vibration at 55-65mph.

Is it ready for the race tomorrow? last car to 50mph buys lunch.
Before and after race....I bet that bro muffler adds 100hp once we install it.

Red85Celica
11-18-2014, 09:09 AM
Replaced some parts...
Got a new headlight and corner light on the car. Picked up a non damaged/non rusted rear bumper, just needs to be color matched.

Replaced the brass thermostat....pretty sure it was original.

Also found a newish starter with receipts at the local pick and pull.

Red85Celica
11-25-2014, 06:03 AM
Up for sale again. My legacy is almost done and its time to move on to another vehicle.

Dead91silvia
11-25-2014, 12:15 PM
Up for sale again. My legacy is almost done and its time to move on to another vehicle.

:smt023

Red85Celica
12-09-2014, 05:31 PM
Cleaned up the car again, installed some replacement parts and took new pictures.

https://sl-i.net/FORUM/images/imported/2014/12/3fb6855972614799bda2983f76fd9835-1.jpg
https://sl-i.net/FORUM/images/imported/2014/12/baf04e94024d6e26d3cc31be5e363fd7-1.jpg
https://sl-i.net/FORUM/images/imported/2014/12/e73a15be9ac8d8bbe7eb281427be2372-1.jpg
https://sl-i.net/FORUM/images/imported/2014/12/0eaac7590137d3db61475a5419691860-1.jpg
https://sl-i.net/FORUM/images/imported/2014/12/90b923b55e3666396bd88d8c53d3b1d7-1.jpg
https://sl-i.net/FORUM/images/imported/2014/12/4f8cfe99610ca1b65bb1b667c6baf6fd-1.jpg
https://sl-i.net/FORUM/images/imported/2014/12/140b015b77e771387d0330423d476cb7-1.jpg
https://sl-i.net/FORUM/images/imported/2014/12/effb95fe3011f01c1f01803719da8981-1.jpg
https://sl-i.net/FORUM/images/imported/2014/12/f95ce69f2e95b1905a562b201cfa9403-1.jpg

Receipt pile stacking up.
https://sl-i.net/FORUM/images/imported/2014/12/4e865838997c0ec40b53ad7478e7e131-1.jpg

Muse
12-10-2014, 08:53 PM
Those Peugeot wheels are great on this thing.

Red85Celica
12-13-2014, 02:28 AM
Might just have to keep this fucking thing and lift it 6".

Muse
12-14-2014, 11:01 AM
I wouldn't stop you. But if you did, you'd have to come over here, and do a photoshoot with SubaFreak. Maybe collect Superu on your way, have a 'stupidly tall Subaru' thing.

Red85Celica
12-27-2014, 02:57 PM
Sold the other day.

Muse
12-28-2014, 05:31 PM
Congrats.

Muse
12-28-2014, 05:31 PM
Congrats.

Crazyeights
10-22-2017, 06:41 PM
This car is still running well and fun to drive! The left rear strut was noisy so I replaced both of the rears and it's totally quiet to drive now. I bought a JDM 30k EA82T engine for it (from Foreign Engines in Lynnwood) at the same time that I bought the car from you because I knew the engine was a little noisy and has low oil pressure. I still haven't had to install it yet but I plan too in the near future.

Thanks again Brad for all of the work you and friends did on saving this car.