PDA

View Full Version : Problem - huge - :|



Nite_net
12-14-2006, 04:54 AM
Hey guys, so here's the story.

I was drivin tonight, went to get pizza, got my pizza, went to start the car again... it fired, reved to 1,500rpm (like usual in the cold) ... then died.

Alright, so i restart it -- same thing happens.

Damnit.

Restart, it just cranks, nothing more than just cranks.
There's ample fuel in the vehicle, it's at full i filled it before i went to get pizza.


Heres the only thing i've done to the vehicle this month...

New H4 90W/135W bulbs (not legal, i know, i know... lol)-- cause the old ones burnt out.

Strange thing is i heard a popping sound before the vehicle just stopped running...almost like a fuse blowing.

this is a BC model, runnin a few of a lot of KMs.
A new fuel pump isn't that bad if it's in need of one, i'm just curious if anyone has any suggestions first hand... cause i can't find the fuel pump. I've looked under the rear seats and found nothing.


HELP.

GrassyKnoll
12-14-2006, 08:57 AM
So it always revs to 1500 then dies? It works fine at anything below 1500?


My friend had this problem with his WRX, it was a cracked y-pipe. Every time he got to 1400 RPM his computer shut the vehicle down.

This can happen with one of two things:

Too much boost running through shitty / stock parts or not allowing the car to heat up when its really cold :)

Hope this helps

Huffer
12-14-2006, 09:06 AM
Bad Air Flow Meter?
No spark (bad coils/wires)
No fuel - fuel pump under back seat, under metal hatch.

Plays_with_Toys
12-14-2006, 10:28 AM
The korean's car was doing something similar, it'd start every time get up to an RPM then just die out. He unplugged the maf and it went into limp mode, but it atleast drove.

Nite_net
12-14-2006, 03:37 PM
Ripped the MAF off, nothing.

It won't start anymore, it just cranks and cranks...
it's very odd, is there a fuse or relay for the fuel pump?

I don't think there's a hatch behind the rear seats guys... it's a big metal plate... lol

I'm getting spark.

:| i'm confused... highly.

GrassyKnoll
12-14-2006, 03:39 PM
if you are definately getting spark... fuel would be the only thing that makes sense

Huffer
12-14-2006, 03:53 PM
UNDER the rear seat bottom.

Nite_net
12-14-2006, 04:12 PM
There is no hatch Huffer, it's seriously one big metal construction with about 4 wires that go into it lol, if it weren't i'd have ripped it open by now.

I'm near the point of having it towed and sent off to a professional... near.

**Edit** by behind i meant under. Sorry.

shazapple
12-14-2006, 04:15 PM
have you actually replaced the fuse for the pump?

Does subaru have a switch that disconnects the fuel pump in case of an addicent? maybe that just got old

Nite_net
12-14-2006, 04:24 PM
Lol!

I've been trying to find if there's a fuse since last night!
Nothing i can find though... anyone?

Huffer
12-14-2006, 04:27 PM
There is no hatch Huffer, it's seriously one big metal construction with about 4 wires that go into it lol, if it weren't i'd have ripped it open by now.

The wires go into something - that should be the removable plate.

Huffer
12-14-2006, 04:28 PM
Lol!

I've been trying to find if there's a fuse since last night!
Nothing i can find though... anyone?

Check both fuse boxes - engine bay and under the dash by the driver's door.

Nite_net
12-14-2006, 04:40 PM
yeah, but any idea what it'd be labeled? cause it's definatly not "pump" or "Fuel pump"... hahahaha another hour and i'll just have it towed to a mechanic... probably cost me another 300$ to get it running again, but hey...that's life?

rougeben83
12-14-2006, 04:46 PM
Put the key in ACC, you should hear a faint whirring sound coming from the back; that's your fuel pump priming the gas lines. If you don't hear that, odds are your pump isn't working.

Also, for the cutoff switch, it should be in the trunk/cargo area behind a side panel somewhere (like most vehicles).

Huffer
12-14-2006, 04:48 PM
yeah, but any idea what it'd be labeled? cause it's definatly not "pump" or "Fuel pump"... hahahaha another hour and i'll just have it towed to a mechanic... probably cost me another 300$ to get it running again, but hey...that's life?

The hatch that I am referring to is the access panel INTO the fuel tank. It's where the fuel pump sits.

Nite_net
12-15-2006, 03:20 AM
So an update for you all,

I had the car towed, and got it in the shop.

a few hours later i got a phone call and they asked if i could come down.

HOLY man.

They showed me the fuel relay... it smoked itself man, it melted itself into oblivion!

Which would explain why i had no fuel... hahah, and when it fried the relay, it apprently fried the fuel pump...

New relay - 30$
New fuel pump - 145$
Shop time - 200$
Tow Truck - 100$

JUST in time for CHRISTMAS!! (and me heading back to Vancouver...LOL)

Let's hope this is the last major repair crap i gotta deal with for a bit.

Later,

Nat.

GrassyKnoll
12-15-2006, 09:41 AM
Yea that's not terrible though,

I'm having the fuel pump replaced at the dealership now and its $400 just for parts :|

Unfortunately I don't have a choice in the matter because it isn't my car anymore :cry: