PDA

View Full Version : Cruise control dillema?



d1giPhux
03-21-2007, 11:36 AM
So, my cruise control WAS working the last time i used it. Since then, i have just installed a short ram intake, and cleaned my engine bay. Not that it should really matter... but maybe it will help point you in the right direction. Anyways.. i went to use the cruise control the other day.. the 'cruise' switch turns on and off as normal, but when i press the set button, to set the accel. speed im currently at.. it does not pick up and keep going. Can anyone maybe send me in the right direction as to WHAT may be wrong.. or what to look for so that i can give you more info? Thanks!

Huffer
03-21-2007, 11:41 AM
Cruise control module on the firewall might be out. Check your fuses, and maybe pick up a replacement module.

Also - if your speedometer isn't working (ie. you're rolling and the needle isn't moving) - speed sensor in transmission not working - then the cruise won't work either.

d1giPhux
03-21-2007, 11:44 AM
What fuses should i check? I'm hoping its just a fuse.. control module sounds expensive! =X how much do they usually run.. any clue? How could i test to see if it is indeed the control module? Thanks!

Huffer
03-21-2007, 11:46 AM
There are fuses in the fuse box.
You can search for the module online - it has a part# stamped on it.

You could use that FSM you have hosted, y'know...

d1giPhux
03-21-2007, 11:56 AM
There are fuses in the fuse box.
You can search for the module online - it has a part# stamped on it.

You could use that FSM you have hosted, y'know...

I have the printed papers right out in front of me.. just so you know! :wink:

But.. the FSM does not tell me how to check if the module is dead, or test whether its dead.. or if something else might be wrong with it. And WHICH fuse would it be? Is there a completely seperate fuse just for the cruise control.. or what?

auspex
03-22-2007, 01:20 AM
this reminds me to check mine..

my cruise control doesn't work when my lights are on!! if the cruise is on when the lights are off and you turn them on, the cruise shuts down.

electrical snafu. damnit.

mike

d1giPhux
03-22-2007, 01:00 PM
this reminds me to check mine..

my cruise control doesn't work when my lights are on!! if the cruise is on when the lights are off and you turn them on, the cruise shuts down.

electrical snafu. damnit.

mike

I wonder what might have caused that? Thats weird.. cause inbetween the time my lights were installed and now.. is when it stopped working? Hmm.. might have to try that out on the drive home this afternoon. I wonder why it would be doing that.. so weird.