Results 1 to 3 of 3

Thread: 1999 legacy gt all cylinder misfire

  1. #1

    1999 legacy gt all cylinder misfire

    Hello. I have a 1999 legacy gt and I have been having a weird problem that is driving me crazy. While driving the car it will randomly and violently loose power like it just completely shut the engine off. Every single cylinder will stop firing and the car will start dueling and just as fast it will start running normal. Generally the hole ordeal last a second but every now and again it will shit of for 4 or 5 second or just completly shut off. I have replaced the cam and crank position sensor, checked all of the electrical connections, replaced the spark plugs with the correct double plantum plugs. This problem happened a few months ago and after I replaced the spark plug it had no problem for 3 ish months until today. Now it’s back and I can not figure out what’s wrong. I have done a recen oil change and there was no evidence of motor damage and I have recently inspected the timing belt and it’s parts and found no problems. I just replaced the coil pack and it made it better but the problem is still there. Does any one have any ideas?

  2. #2
    "FNG" Kamion's Avatar
    Join Date
    Aug 2016
    Location
    Slovenia
    Posts
    26
    Points
    708
    Level
    14
    Points: 708, Level: 14
    Level completed: 8%, Points required for next Level: 92
    Achievements:
    3 months registered500 Experience Points
    Did you replaced spark plug cables? If not start with them.
    Subaru Legacy GL EJ20 (BH, year 2002)

  3. #3
    SLi nOOb
    Join Date
    Feb 2012
    Posts
    199
    Points
    4,028
    Level
    40
    Points: 4,028, Level: 40
    Level completed: 39%, Points required for next Level: 122
    Achievements:
    Veteran1000 Experience Points
    stop filling up at the gas station you last filled up at

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •